The "All Things Triumph" Public Forum

Sponsored by the Vintage Triumph Register

ATTENTION MEMBERS: For security reasons, the VTR Forum requires separate registration, your membership log-in will not work.

Please consider registering
guest

Log In Register Members

Register | Lost password?
Advanced Search

— Forum Scope —

  

— Match —

   

— Forum Options —

   

Wildcard usage:
*  matches any number of characters    %  matches exactly one character

Minimum search word length is 4 characters - maximum search word length is 84 characters

Topic RSS
Rings or water pump
August 3, 2015
12:35 pm
Thepi1971
Guest

Hi All

Did some searching and can find no info on a problem I'm having with a recently purchased 1979 TR7 2.0 Litre so forgive if I'm reposting. Recently started having problems with oil blowing from places it shouldn't while driving and mostly above 3000rpms. Started with the oil dipstick tube; discovered that there was no felt washer or extra piece that holds the dipstick in place while in the tube. Replaced washer and fabricated a clip to hold it and it stopped leaking from there. A day or two later I still had the dreaded smoke coming from the engine bay while driving. Now it appears to be venting from the Oil filler cap (new cork seal en route) as well as out the weep hole for the water pump. I did a compression test and #1 (front most) cylinder was indeed lower (35) compared to the others (around 90) and did come up to around 100 when 4 tablespoons of oil was placed in low cylinder and re-tested. My question would be could this just be the oil seal on the water pump shaft instead of ring problems or some combination of both with a side of head gasket failure? Not sure how the oil is even getting in there as I cannot find any diagram showing weather there is some connection between the in engine water pump housing and the front-most cylinder. i've also checked most of the breathing tubes and appear to at least be letting air through all the way to the carbon canisters as when any part is removed it changes the idle of the engine. Previous owners removed the air pump cat and center silencer but all else appears to be intact and functional.

Any help is truly appreciated

Kevin R

Forum Timezone: America/Detroit

Most Users Ever Online: 69

Currently Online:
7 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

charley fitch: 446

vila: 65

labelle: 17

donbmw: 12

TR6nITJulius: 12

Member Stats:

Guest Posters: 877

Members: 120

Moderators: 0

Admins: 0

Forum Stats:

Groups: 5

Forums: 23

Topics: 1520

Posts: 4745

Administrators: